summaryrefslogtreecommitdiffstats
path: root/tdeabc/vcardparser/CMakeLists.txt
diff options
context:
space:
mode:
authorEmanoil Kotsev <deloptes@gmail.com>2016-09-26 21:20:31 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2016-09-26 21:25:15 +0900
commit83681c9b08996739e7c17100e5e85eaee18d24ad (patch)
tree16e804b49d19591e4e4fd24c3703aa6edbb2653b /tdeabc/vcardparser/CMakeLists.txt
parent515aec93f3ab3da6298b0d895710202647de2ab1 (diff)
downloadtdelibs-83681c9b08996739e7c17100e5e85eaee18d24ad.tar.gz
tdelibs-83681c9b08996739e7c17100e5e85eaee18d24ad.zip
Fixed vcardparser tests during building. This resolves bug 2695.
Signed-off-by: Emanoil Kotsev <deloptes@gmail.com> Removed not-required part of the patch from original Emanoil's patch (empty spaces at the end of line) Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 13e032939ea40c33e4964b54bf755a6f1c9d70be)
Diffstat (limited to 'tdeabc/vcardparser/CMakeLists.txt')
-rw-r--r--tdeabc/vcardparser/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/tdeabc/vcardparser/CMakeLists.txt b/tdeabc/vcardparser/CMakeLists.txt
index 8e916aa0b..632c4fb9f 100644
--- a/tdeabc/vcardparser/CMakeLists.txt
+++ b/tdeabc/vcardparser/CMakeLists.txt
@@ -90,9 +90,14 @@ tde_add_executable( testvcardformatimpl
LINK ${TDEABC_TESTS_LINK}
)
-add_custom_target(testing ALL
- COMMAND echo "creating test infrastructure"
- DEPENDS testread
+add_custom_target(test ALL echo "performing tests on vcardparser"
+ COMMAND bash ./test.sh
+ DEPENDS testing
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+add_custom_target(testing ALL echo "creating test infrastructure"
+ DEPENDS testvcardformatimpl testvcardformat testwrite2 testwrite testread2 testread
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)