summaryrefslogtreecommitdiffstats
path: root/tdecore/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:48:13 +0200
commit9756408b0ebb206b53abd2597926d8fead731977 (patch)
tree62caa2c2ebd6ebccc5472fdc7469fe54dad8b24f /tdecore/CMakeLists.txt
parentc95c7a29338aa309fab071b5a4475400fdce97a8 (diff)
downloadtdelibs-9756408b0ebb206b53abd2597926d8fead731977.tar.gz
tdelibs-9756408b0ebb206b53abd2597926d8fead731977.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4b7a4e17362206fd2eade35ba947a850263b0ea1)
Diffstat (limited to 'tdecore/CMakeLists.txt')
-rw-r--r--tdecore/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/tdecore/CMakeLists.txt b/tdecore/CMakeLists.txt
index 7bccb3a59..c96f5c905 100644
--- a/tdecore/CMakeLists.txt
+++ b/tdecore/CMakeLists.txt
@@ -79,8 +79,11 @@ install( FILES
##### other data ################################
-install( FILES all_languages.desktop
- DESTINATION ${LOCALE_INSTALL_DIR} RENAME all_languages )
+tde_create_translated_desktop(
+ SOURCE all_languages.desktop
+ DESTINATION ${LOCALE_INSTALL_DIR}
+ OUTPUT_NAME all_languages
+)
install( FILES 40.colors Web.colors Royal.colors Rainbow.colors
DESTINATION ${CONFIG_INSTALL_DIR}/colors )
@@ -91,8 +94,11 @@ install( FILES kdebug.areas kdebugrc language.codes
install( FILES kmdcodec_compat.h
DESTINATION ${INCLUDE_INSTALL_DIR}/tdeio RENAME kmdcodec.h )
-install( FILES eventsrc
- DESTINATION ${DATA_INSTALL_DIR}/knotify )
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/knotify
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdecore-eventsrc
+)
##### libtdecore ################################