summaryrefslogtreecommitdiffstats
path: root/tdecore/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /tdecore/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdecore/CMakeLists.txt')
-rw-r--r--tdecore/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/tdecore/CMakeLists.txt b/tdecore/CMakeLists.txt
index fb39d1bea..e9b909acc 100644
--- a/tdecore/CMakeLists.txt
+++ b/tdecore/CMakeLists.txt
@@ -80,8 +80,11 @@ install( FILES
##### other data ################################
-install( FILES all_languages.desktop
- DESTINATION ${LOCALE_INSTALL_DIR} RENAME all_languages )
+tde_create_translated_desktop(
+ SOURCE all_languages.desktop
+ DESTINATION ${LOCALE_INSTALL_DIR}
+ OUTPUT_NAME all_languages
+)
install( FILES 40.colors Web.colors Royal.colors Rainbow.colors
DESTINATION ${CONFIG_INSTALL_DIR}/colors )
@@ -92,8 +95,11 @@ install( FILES kdebug.areas kdebugrc language.codes
install( FILES kmdcodec_compat.h
DESTINATION ${INCLUDE_INSTALL_DIR}/tdeio RENAME kmdcodec.h )
-install( FILES eventsrc
- DESTINATION ${DATA_INSTALL_DIR}/knotify )
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/knotify
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdecore-eventsrc
+)
##### libtdecore ################################