summaryrefslogtreecommitdiffstats
path: root/tdefx/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
commite16866e072f94410321d70daedbcb855ea878cac (patch)
treeee3f52eabde7da1a0e6ca845fb9c2813cf1558cf /tdefx/CMakeLists.txt
parenta58c20c1a7593631a1b50213c805507ebc16adaf (diff)
downloadtdelibs-e16866e072f94410321d70daedbcb855ea878cac.tar.gz
tdelibs-e16866e072f94410321d70daedbcb855ea878cac.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdefx/CMakeLists.txt')
-rw-r--r--tdefx/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/tdefx/CMakeLists.txt b/tdefx/CMakeLists.txt
new file mode 100644
index 000000000..1aa52627f
--- /dev/null
+++ b/tdefx/CMakeLists.txt
@@ -0,0 +1,48 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdecore
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ kpixmap.h kpixmapsplitter.h kpixmapeffect.h
+ kimageeffect.h kdrawutil.h kstyle.h kcpuinfo.h
+ DESTINATION ${INCLUDE_INSTALL_DIR} )
+
+
+##### libtdefx ##################################
+
+set( target tdefx )
+
+set( ${target}_SRCS
+ kpixmap.cpp kpixmapsplitter.cpp kpixmapeffect.cpp
+ kimageeffect.cpp kdrawutil.cpp kstyle.cpp kcpuinfo.cpp
+)
+
+tde_add_library( ${target} SHARED AUTOMOC
+ SOURCES ${${target}_SRCS}
+ VERSION 4.2.0
+ LINK ${TQT_LIBRARIES} ${XRENDER_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+)