summaryrefslogtreecommitdiffstats
path: root/tdeio/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-04-18 18:58:23 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-04-18 18:58:23 -0500
commit30b0af1f01cdbfcc51a56943e8c091bc8991f83a (patch)
treec9e257fb983d474f8f2ccd9753c76c8e2c4e5b46 /tdeio/CMakeLists.txt
parenta37d43794f4369915068f585f6ff4720e93dd2af (diff)
downloadtdelibs-30b0af1f01cdbfcc51a56943e8c091bc8991f83a.tar.gz
tdelibs-30b0af1f01cdbfcc51a56943e8c091bc8991f83a.zip
Fix URL handling of media/builtin-* mimetypes
This partially resolves Bug 976 Add missing ACL support to CMake build files
Diffstat (limited to 'tdeio/CMakeLists.txt')
-rw-r--r--tdeio/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tdeio/CMakeLists.txt b/tdeio/CMakeLists.txt
index 826fbf743..bdb545c95 100644
--- a/tdeio/CMakeLists.txt
+++ b/tdeio/CMakeLists.txt
@@ -55,6 +55,10 @@ if( HAVE_ELFICON )
set( ELFICON_STATIC_LIB tdelficon-static )
endif( HAVE_ELFICON )
+if( HAVE_NON_POSIX_ACL_EXTENSIONS )
+ set( ACL_LIBRARIES acl )
+endif( HAVE_NON_POSIX_ACL_EXTENSIONS )
+
##### libtdeio ####################################
@@ -66,6 +70,6 @@ tde_add_library( ${target} SHARED
SOURCES ${CMAKE_CURRENT_BINARY_DIR}/dummy.cpp
VERSION 4.2.0
EMBED kssl-static tdeiocore-static tdesycoca-static kbookmarks-static tdefile-static ${ELFICON_STATIC_LIB}
- LINK ltdlc-static tdeui-shared tdesu-shared tdewalletclient-shared ${LIBR_LIBRARIES}
+ LINK ltdlc-static tdeui-shared tdesu-shared tdewalletclient-shared ${LIBR_LIBRARIES} ${ACL_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)