summaryrefslogtreecommitdiffstats
path: root/tdeio/misc/kpac/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /tdeio/misc/kpac/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdeio/misc/kpac/CMakeLists.txt')
-rw-r--r--tdeio/misc/kpac/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/tdeio/misc/kpac/CMakeLists.txt b/tdeio/misc/kpac/CMakeLists.txt
index 7d2c22d63..bd41c5887 100644
--- a/tdeio/misc/kpac/CMakeLists.txt
+++ b/tdeio/misc/kpac/CMakeLists.txt
@@ -30,8 +30,17 @@ link_directories(
##### other data ################################
-install(FILES proxyscout.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
-install(FILES eventsrc DESTINATION ${DATA_INSTALL_DIR}/proxyscout )
+tde_create_translated_desktop(
+ SOURCE proxyscout.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeio-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE eventsrc
+ DESTINATION ${DATA_INSTALL_DIR}/proxyscout
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeio-kpac-eventsrc
+)
##### kded_proxyscout ###########################