summaryrefslogtreecommitdiffstats
path: root/tdeio/misc/kpac/Makefile.am
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
commit7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f (patch)
treec76702a7f6310fbe9d437e347535422e836e94e9 /tdeio/misc/kpac/Makefile.am
parenta2a38be7600e2a2c2b49c66902d912ca036a2c0f (diff)
parent27bbee9a5f9dcda53d8eb23863ee670ad1360e41 (diff)
downloadtdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.tar.gz
tdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'tdeio/misc/kpac/Makefile.am')
-rw-r--r--tdeio/misc/kpac/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/tdeio/misc/kpac/Makefile.am b/tdeio/misc/kpac/Makefile.am
new file mode 100644
index 000000000..beb6a4b86
--- /dev/null
+++ b/tdeio/misc/kpac/Makefile.am
@@ -0,0 +1,30 @@
+
+kde_module_LTLIBRARIES = kded_proxyscout.la
+bin_PROGRAMS = kpac_dhcp_helper
+
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/libltdl -I$(top_srcdir)/kded -I$(top_builddir)/kjs \
+ -I$(top_srcdir)/tdecore/network $(all_includes)
+METASOURCES = AUTO
+KDE_CXXFLAGS = $(USE_EXCEPTIONS)
+
+kded_proxyscout_la_SOURCES = proxyscout.skel proxyscout.cpp script.cpp \
+ downloader.cpp discovery.cpp
+kded_proxyscout_la_LDFLAGS = $(all_libraries) -module -avoid-version
+kded_proxyscout_la_LIBADD = $(LIB_KIO) $(top_builddir)/kjs/libkjs.la $(LIB_KDED) $(LIB_QT) \
+ $(top_builddir)/dcop/libDCOP.la $(LIB_TDECORE) $(LIBRESOLV)
+
+kpac_dhcp_helper_SOURCES = kpac_dhcp_helper.c
+kpac_dhcp_helper_CFLAGS = $(KDE_USE_FPIE)
+kpac_dhcp_helper_LDFLAGS = $(KDE_USE_PIE)
+kpac_dhcp_helper_LDADD = $(LIBSOCKET)
+
+noinst_HEADERS = proxyscout.h script.h downloader.h discovery.h
+
+servicesdir = $(kde_servicesdir)/kded
+services_DATA = proxyscout.desktop
+
+proxyscoutdatadir = $(kde_datadir)/proxyscout
+proxyscoutdata_DATA = eventsrc
+
+install-exec-local:
+ @(chown root $(DESTDIR)$(bindir)/kpac_dhcp_helper && chmod 4755 $(DESTDIR)$(bindir)/kpac_dhcp_helper) || echo "Please make kpac_dhcp_helper setuid root"