summaryrefslogtreecommitdiffstats
path: root/tdeio/misc/tdefile/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /tdeio/misc/tdefile/Makefile.am
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeio/misc/tdefile/Makefile.am')
-rw-r--r--tdeio/misc/tdefile/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tdeio/misc/tdefile/Makefile.am b/tdeio/misc/tdefile/Makefile.am
new file mode 100644
index 000000000..21cdb0627
--- /dev/null
+++ b/tdeio/misc/tdefile/Makefile.am
@@ -0,0 +1,10 @@
+METASOURCES = AUTO
+
+noinst_HEADERS = fileprops.h
+INCLUDES= -I$(top_srcdir) -I$(top_srcdir)/tdeio/tdeio $(all_includes)
+
+bin_PROGRAMS = tdefile
+tdefile_SOURCES = fileprops.cpp
+tdefile_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+tdefile_LDADD = $(LIB_KIO)
+