summaryrefslogtreecommitdiffstats
path: root/tdeio/tdefile/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /tdeio/tdefile/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdeio/tdefile/CMakeLists.txt')
-rw-r--r--tdeio/tdefile/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tdeio/tdefile/CMakeLists.txt b/tdeio/tdefile/CMakeLists.txt
index 8952005ed..67f228477 100644
--- a/tdeio/tdefile/CMakeLists.txt
+++ b/tdeio/tdefile/CMakeLists.txt
@@ -47,9 +47,11 @@ install( FILES
##### other data ################################
-install( FILES
- kpropsdlgplugin.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kpropsdlgplugin.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeio-desktops
+)
##### tdefile #####################################