summaryrefslogtreecommitdiffstats
path: root/tdeio/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-12-06 10:50:13 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-12-06 10:50:13 +0100
commit19f44e5ff3756172540e768fc0d08d761f0c374e (patch)
tree962f74609254b68bdf67dbd25e91421fbaedfbce /tdeio/tests/CMakeLists.txt
parent1f1bd93ca8a699e5acae0b9dc7d9ee25189954d9 (diff)
downloadtdelibs-19f44e5ff3756172540e768fc0d08d761f0c374e.tar.gz
tdelibs-19f44e5ff3756172540e768fc0d08d761f0c374e.zip
tests: Wait for the dcop server to be ready.
Use a separate ICEAUTHORITY for tests. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdeio/tests/CMakeLists.txt')
-rw-r--r--tdeio/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tdeio/tests/CMakeLists.txt b/tdeio/tests/CMakeLists.txt
index 323a7d86e..e9f5ea5ff 100644
--- a/tdeio/tests/CMakeLists.txt
+++ b/tdeio/tests/CMakeLists.txt
@@ -80,6 +80,7 @@ configure_file( kmimetypetest.sh.cmake kmimetypetest.sh @ONLY )
add_test( NAME "tdeio/kmimetypetest"
COMMAND sh -x "${CMAKE_CURRENT_BINARY_DIR}/kmimetypetest.sh"
WORKING_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}" )
+set_tests_properties( "tdeio/kmimetypetest" PROPERTIES TIMEOUT 30)
# TODO add kdirwatchunittest