summaryrefslogtreecommitdiffstats
path: root/tdeio/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-12-21 01:09:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2017-01-29 02:27:15 +0100
commited74769bfaae171809c0bc1a10a8ba0f6ff8895f (patch)
tree2be1a9e1f24c538b0f682e733794336f6fe54193 /tdeio/tests/CMakeLists.txt
parentd556a8752c0862aa2d84a105dc8ac41b61ba7824 (diff)
downloadtdelibs-ed74769bfaae171809c0bc1a10a8ba0f6ff8895f.tar.gz
tdelibs-ed74769bfaae171809c0bc1a10a8ba0f6ff8895f.zip
tdeio: add tests
Signed-off-by: Alexander Golubev <fatzer2@gmail.com>
Diffstat (limited to 'tdeio/tests/CMakeLists.txt')
-rw-r--r--tdeio/tests/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tdeio/tests/CMakeLists.txt b/tdeio/tests/CMakeLists.txt
index a9f6bd4ef..b8b9a411a 100644
--- a/tdeio/tests/CMakeLists.txt
+++ b/tdeio/tests/CMakeLists.txt
@@ -11,8 +11,14 @@
include_directories(
${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/dcop
${CMAKE_BINARY_DIR}/tdecore
${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeui
+ ${CMAKE_SOURCE_DIR}/tdeio
+ ${CMAKE_SOURCE_DIR}/tdeio/tdefile
${CMAKE_SOURCE_DIR}/tdeio/tdeio
)
@@ -34,3 +40,37 @@ tde_add_executable( ${target}
LINK tdeio-shared
DESTINATION ${BIN_INSTALL_DIR}
)
+
+
+##### check and test ##############################
+
+# Force assertions to work
+add_definitions( -UNDEBUG )
+
+set( CHECKS
+ getalltest jobtest kdcopcheck kdefaultprogresstest kdirlistertest
+ kdirwatchtest kfiltertest kionetrctest kiopassdlgtest kmfitest kmimefromext
+ kmimemagictest kpropsdlgtest kprotocolinfotest kruntest kscantest kshredtest
+ ktartest kurifiltertest kurlcompletiontest kziptest metatest netaccesstest
+ previewtest speed tdeioslavetest tdesycocatest tdesycocaupdatetest
+)
+
+foreach( _check ${CHECKS} )
+ tde_add_check_executable( ${_check} AUTOMOC LINK tdeio-shared )
+endforeach( )
+
+# NOTE some apps here are suitable to be run as tests but not included due to
+# following reasons:
+# - jobtest may fail if run on an unusual system configuration
+# and requires GUI
+# - kprotocolinfotest tries to connect to network and requires running DCOP
+# - kurifiltertest requires network access and GUI
+# - tdesycocatest requires installed tdebase and GUI
+
+set( TESTS dataprotocoltest kacltest kmimetypetest )
+
+foreach( _check ${TESTS} )
+ tde_add_check_executable( ${_check} AUTOMOC LINK tdeio-shared TEST)
+endforeach( )
+
+# TODO add kdirwatchunittest