summaryrefslogtreecommitdiffstats
path: root/tdeioslave/bzip2/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /tdeioslave/bzip2/Makefile.am
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/bzip2/Makefile.am')
-rw-r--r--tdeioslave/bzip2/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tdeioslave/bzip2/Makefile.am b/tdeioslave/bzip2/Makefile.am
new file mode 100644
index 000000000..963f27e31
--- /dev/null
+++ b/tdeioslave/bzip2/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES = -I$(top_srcdir)/tdeio $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kbzip2filter.la
+
+kbzip2filter_la_SOURCES = kbzip2filter.cpp
+kbzip2filter_la_LIBADD = $(LIB_KIO) $(LIBBZ2) $(LIB_QT) $(LIB_TDECORE)
+kbzip2filter_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+kde_services_DATA = kbzip2filter.desktop
+