summaryrefslogtreecommitdiffstats
path: root/tdeioslave/http/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
commit7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f (patch)
treec76702a7f6310fbe9d437e347535422e836e94e9 /tdeioslave/http/CMakeLists.txt
parenta2a38be7600e2a2c2b49c66902d912ca036a2c0f (diff)
parent27bbee9a5f9dcda53d8eb23863ee670ad1360e41 (diff)
downloadtdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.tar.gz
tdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'tdeioslave/http/CMakeLists.txt')
-rw-r--r--tdeioslave/http/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/tdeioslave/http/CMakeLists.txt b/tdeioslave/http/CMakeLists.txt
new file mode 100644
index 000000000..aff6d0a4e
--- /dev/null
+++ b/tdeioslave/http/CMakeLists.txt
@@ -0,0 +1,69 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( kcookiejar )
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdecore/network
+ ${CMAKE_SOURCE_DIR}/interfaces
+ ${CMAKE_SOURCE_DIR}/tdeio
+ ${CMAKE_SOURCE_DIR}/tdeio/tdeio
+ ${CMAKE_SOURCE_DIR}/tdeio/httpfilter
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES
+ http_cache_cleaner.desktop http.protocol https.protocol
+ webdav.protocol webdavs.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### tdeio_http_cache_cleaner ####################
+
+set( target tdeio_http_cache_cleaner )
+
+set( ${target}_SRCS
+ http_cache_cleaner.cpp
+)
+
+tde_add_tdeinit_executable( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdeio-shared
+)
+
+
+##### tdeio_http ##################################
+
+# FIXME GSSAPI support is not handled yet
+
+set( target tdeio_http )
+
+set( ${target}_SRCS
+ http.cc
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK httpfilter-static tdentlm-shared tdeio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)