summaryrefslogtreecommitdiffstats
path: root/tdeioslave/http/kcookiejar/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:48:13 +0200
commit9756408b0ebb206b53abd2597926d8fead731977 (patch)
tree62caa2c2ebd6ebccc5472fdc7469fe54dad8b24f /tdeioslave/http/kcookiejar/CMakeLists.txt
parentc95c7a29338aa309fab071b5a4475400fdce97a8 (diff)
downloadtdelibs-9756408b0ebb206b53abd2597926d8fead731977.tar.gz
tdelibs-9756408b0ebb206b53abd2597926d8fead731977.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 4b7a4e17362206fd2eade35ba947a850263b0ea1)
Diffstat (limited to 'tdeioslave/http/kcookiejar/CMakeLists.txt')
-rw-r--r--tdeioslave/http/kcookiejar/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tdeioslave/http/kcookiejar/CMakeLists.txt b/tdeioslave/http/kcookiejar/CMakeLists.txt
index 164f6ccd0..57feb62b2 100644
--- a/tdeioslave/http/kcookiejar/CMakeLists.txt
+++ b/tdeioslave/http/kcookiejar/CMakeLists.txt
@@ -27,8 +27,14 @@ link_directories(
##### other data ################################
-install( FILES kcookiejar.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+tde_create_translated_desktop(
+ SOURCE kcookiejar.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeioslave-desktops
+)
+
install( FILES kcookiescfg.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+
install( FILES domain_info DESTINATION ${DATA_INSTALL_DIR}/tdehtml )