summaryrefslogtreecommitdiffstats
path: root/tdeioslave/http/kcookiejar/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /tdeioslave/http/kcookiejar/CMakeLists.txt
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/http/kcookiejar/CMakeLists.txt')
-rw-r--r--tdeioslave/http/kcookiejar/CMakeLists.txt63
1 files changed, 63 insertions, 0 deletions
diff --git a/tdeioslave/http/kcookiejar/CMakeLists.txt b/tdeioslave/http/kcookiejar/CMakeLists.txt
new file mode 100644
index 000000000..289daa4f0
--- /dev/null
+++ b/tdeioslave/http/kcookiejar/CMakeLists.txt
@@ -0,0 +1,63 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeui
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kcookiejar.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+install( FILES kcookiescfg.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+install( FILES domain_info DESTINATION ${DATA_INSTALL_DIR}/tdehtml )
+
+
+##### kcookiejar ################################
+
+set( target kcookiejar )
+
+set( ${target}_SRCS
+ main.cpp
+)
+
+tde_add_tdeinit_executable( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdecore-shared
+)
+
+
+##### kded_kcookiejar ###########################
+
+set( target kded_kcookiejar )
+
+set( ${target}_SRCS
+ kcookiejar.cpp kcookieserver.cpp kcookiewin.cpp
+ kcookieserver.skel
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdeui-shared tdeinit_kded-shared
+ DEPENDENCIES dcopidl
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)