summaryrefslogtreecommitdiffstats
path: root/tdeparts/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /tdeparts/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdeparts/CMakeLists.txt')
-rw-r--r--tdeparts/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tdeparts/CMakeLists.txt b/tdeparts/CMakeLists.txt
index 341734461..497b82ced 100644
--- a/tdeparts/CMakeLists.txt
+++ b/tdeparts/CMakeLists.txt
@@ -40,9 +40,15 @@ install( FILES
##### other data ################################
-install( FILES
+foreach( _desktop
kpart.desktop krop.desktop krwp.desktop browserview.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeparts-desktops
+ )
+endforeach()
#### tdeparts #####################################