summaryrefslogtreecommitdiffstats
path: root/tdeprint/tools/escputil/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
commite16866e072f94410321d70daedbcb855ea878cac (patch)
treeee3f52eabde7da1a0e6ca845fb9c2813cf1558cf /tdeprint/tools/escputil/CMakeLists.txt
parenta58c20c1a7593631a1b50213c805507ebc16adaf (diff)
downloadtdelibs-e16866e072f94410321d70daedbcb855ea878cac.tar.gz
tdelibs-e16866e072f94410321d70daedbcb855ea878cac.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeprint/tools/escputil/CMakeLists.txt')
-rw-r--r--tdeprint/tools/escputil/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tdeprint/tools/escputil/CMakeLists.txt b/tdeprint/tools/escputil/CMakeLists.txt
new file mode 100644
index 000000000..3494d3cfb
--- /dev/null
+++ b/tdeprint/tools/escputil/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeui
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES escputil.desktop DESTINATION ${DATA_INSTALL_DIR}/tdeprint/tools )
+
+
+##### tdeprint_tool_escputil ####################
+
+set( target tdeprint_tool_escputil )
+
+set( ${target}_SRCS
+ escpwidget.cpp
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdeui-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)