summaryrefslogtreecommitdiffstats
path: root/tdespell2/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
commit7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f (patch)
treec76702a7f6310fbe9d437e347535422e836e94e9 /tdespell2/CMakeLists.txt
parenta2a38be7600e2a2c2b49c66902d912ca036a2c0f (diff)
parent27bbee9a5f9dcda53d8eb23863ee670ad1360e41 (diff)
downloadtdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.tar.gz
tdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'tdespell2/CMakeLists.txt')
-rw-r--r--tdespell2/CMakeLists.txt59
1 files changed, 59 insertions, 0 deletions
diff --git a/tdespell2/CMakeLists.txt b/tdespell2/CMakeLists.txt
new file mode 100644
index 000000000..01b910862
--- /dev/null
+++ b/tdespell2/CMakeLists.txt
@@ -0,0 +1,59 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( ui )
+add_subdirectory( plugins )
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeui
+ ${CMAKE_SOURCE_DIR}/tdeutils
+ ${CMAKE_SOURCE_DIR}/tdeio
+ ${CMAKE_SOURCE_DIR}/tdeio/tdeio
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ settings.h filter.h dictionary.h broker.h
+ backgroundchecker.h defaultdictionary.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/tdespell2 )
+
+
+##### other data ################################
+
+install( FILES tdespellclient.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+
+#### tdespell2base ################################
+
+set( target tdespell2base )
+
+set( ${target}_SRCS
+ settings.cpp broker.cpp client.cpp filter.cpp
+ backgroundchecker.cpp backgroundthread.cpp
+ backgroundengine.cpp defaultdictionary.cpp
+)
+
+tde_add_library( ${target} STATIC_PIC AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK ${TQT_LIBRARIES}
+)