summaryrefslogtreecommitdiffstats
path: root/tdespell2/plugins/aspell/Makefile.am
diff options
context:
space:
mode:
authorDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
committerDarrell Anderson <humanreadable@yahoo.com>2013-03-02 15:57:34 -0600
commit7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f (patch)
treec76702a7f6310fbe9d437e347535422e836e94e9 /tdespell2/plugins/aspell/Makefile.am
parenta2a38be7600e2a2c2b49c66902d912ca036a2c0f (diff)
parent27bbee9a5f9dcda53d8eb23863ee670ad1360e41 (diff)
downloadtdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.tar.gz
tdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'tdespell2/plugins/aspell/Makefile.am')
-rw-r--r--tdespell2/plugins/aspell/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tdespell2/plugins/aspell/Makefile.am b/tdespell2/plugins/aspell/Makefile.am
new file mode 100644
index 000000000..4d40583f1
--- /dev/null
+++ b/tdespell2/plugins/aspell/Makefile.am
@@ -0,0 +1,17 @@
+METASOURCES = AUTO
+
+AM_CPPFLAGS = -I$(top_srcdir)/tdespell2 -I$(top_srcdir) $(all_includes)
+
+# For the future: examine if condensing the tons of *_LDFLAGS variables
+# into $(all_libraries) isn't better
+AM_LDFLAGS = $(LDFLAGS_AS_NEEDED) $(LDFLAGS_NEW_DTAGS)
+
+kde_module_LTLIBRARIES = tdespell_aspell.la
+
+tdespell_aspell_la_SOURCES = tdespell_aspellclient.cpp tdespell_aspelldict.cpp
+
+tdespell_aspell_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN)
+tdespell_aspell_la_LIBADD = ../../ui/libtdespell2.la -laspell $(LIB_QT) $(LIB_TDECORE)
+
+service_DATA = tdespell_aspell.desktop
+servicedir = $(kde_servicesdir)