summaryrefslogtreecommitdiffstats
path: root/tdespell2/ui/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
commitdfe289850f068f19ba4a83ab4e7e22a7e09c13c9 (patch)
treec297348a55df66c571de4525646e0b9762427353 /tdespell2/ui/Makefile.am
parentb7658a0d5eca24a9d37c6e04f88298ef02389db0 (diff)
downloadtdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.tar.gz
tdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdespell2/ui/Makefile.am')
-rw-r--r--tdespell2/ui/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tdespell2/ui/Makefile.am b/tdespell2/ui/Makefile.am
new file mode 100644
index 000000000..713270c9d
--- /dev/null
+++ b/tdespell2/ui/Makefile.am
@@ -0,0 +1,21 @@
+METASOURCES = AUTO
+
+lib_LTLIBRARIES = libtdespell2.la
+# Put most of the code in a noinst lib, for the unit tests to be able to use internal classes.
+noinst_LTLIBRARIES = libtdespell2_noinst.la
+
+KDE_CXXFLAGS = -DKDE_NO_COMPAT -DQT_NO_COMPAT
+INCLUDES = -I$(top_srcdir)/tdespell2 $(all_includes)
+
+tdespell2includedir = $(includedir)/tdespell2
+tdespell2include_HEADERS = dialog.h highlighter.h configdialog.h \
+ configwidget.h
+
+libtdespell2_noinst_la_SOURCES = tdespell2ui.ui configwidget.cpp \
+ highlighter.cpp configui.ui configdialog.cpp
+
+dialog.lo: tdespell2ui.h
+
+libtdespell2_la_SOURCES = dialog.cpp
+libtdespell2_la_LDFLAGS = -no-undefined -version-info 1:0:0 $(all_libraries)
+libtdespell2_la_LIBADD = libtdespell2_noinst.la ../libtdespell2base.la ../../tdeutils/libtdeutils.la $(LIB_QT) $(LIB_TDEUI) $(LIB_TDECORE) $(LIB_KFILE)