summaryrefslogtreecommitdiffstats
path: root/tdeui/kdetrayproxy/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
commite16866e072f94410321d70daedbcb855ea878cac (patch)
treeee3f52eabde7da1a0e6ca845fb9c2813cf1558cf /tdeui/kdetrayproxy/CMakeLists.txt
parenta58c20c1a7593631a1b50213c805507ebc16adaf (diff)
downloadtdelibs-e16866e072f94410321d70daedbcb855ea878cac.tar.gz
tdelibs-e16866e072f94410321d70daedbcb855ea878cac.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeui/kdetrayproxy/CMakeLists.txt')
-rw-r--r--tdeui/kdetrayproxy/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/tdeui/kdetrayproxy/CMakeLists.txt b/tdeui/kdetrayproxy/CMakeLists.txt
new file mode 100644
index 000000000..be341b277
--- /dev/null
+++ b/tdeui/kdetrayproxy/CMakeLists.txt
@@ -0,0 +1,46 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/kded
+ ${CMAKE_SOURCE_DIR}/tdecore
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES
+ kdetrayproxy.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+
+
+##### kded_kdetrayproxy #########################
+
+set( target kded_kdetrayproxy )
+
+set( ${target}_SRCS
+ kdetrayproxy.cpp module.cpp module.skel
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdecore-shared tdeinit_kded-shared
+ DEPENDENCIES dcopidl
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)