summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 10 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87201823a..de3701575 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -713,11 +713,16 @@ endif( WITH_LUA )
##### check for avahi ###########################
if( WITH_AVAHI )
- pkg_search_module( AVAHI avahi-qt3 )
- if( NOT AVAHI_FOUND )
- message(FATAL_ERROR "\navahi support are requested, but not found on your system" )
- endif( NOT AVAHI_FOUND )
- set( AVAHI_API_0_6 1 )
+ if( WITH_QT4 )
+ endif( WITH_QT4 )
+
+ if( WITH_QT3 )
+ pkg_search_module( AVAHI avahi-qt3 )
+ if( NOT AVAHI_FOUND )
+ message(FATAL_ERROR "\navahi support are requested, but not found on your system" )
+ endif( NOT AVAHI_FOUND )
+ set( AVAHI_API_0_6 1 )
+ endif( WITH_QT3 )
endif( )
##### check for aspell ##########################