summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6962394a0..86c2fcdda 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,7 @@ OPTION( WITH_JASPER "Enable jasper (jpeg2k) support" OFF )
OPTION( WITH_OPENEXR "Enable openexr support" OFF )
OPTION( WITH_UTEMPTER "Use utempter for utmp management" OFF )
OPTION( WITH_AVAHI "Enable AVAHI support" OFF )
+OPTION( WITH_ELFICON "Enable ELF embedded icon support" OFF )
OPTION( WITH_ASPELL "Enable aspell support" OFF )
OPTION( WITH_HSPELL "Enable hspell support" OFF )
@@ -715,6 +716,26 @@ if( WITH_AVAHI )
endif( WITH_QT3 )
endif( )
+
+##### check for libr ###########################
+# WARNING
+# before altering the LIBR_VERSION check,
+# please ensure that nothing changed in the
+# duplicated data definitions present in
+# kio/kio/kfileitem.cpp
+
+if( WITH_ELFICON )
+ pkg_search_module( LIBR libr )
+ if( NOT LIBR_FOUND )
+ message(FATAL_ERROR "\nelficon support was requested, but libr was not found on your system" )
+ endif( NOT LIBR_FOUND )
+ if( LIBR_VERSION != 0.6.0 )
+ message(FATAL_ERROR "\nelficon support was requested, but the libr version on your system may not be compatible with TDE" )
+ endif( LIBR_VERSION != 0.6.0 )
+ set( HAVE_ELFICON 1 )
+endif( )
+
+
##### check for aspell ##########################
# we need ASPELL_DATADIR too