summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 939a6da36..420eed83d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,6 +76,7 @@ OPTION( WITH_OPENEXR "Enable openexr support" OFF )
OPTION( WITH_UTEMPTER "Use utempter for utmp management" OFF )
OPTION( WITH_AVAHI "Enable AVAHI support" OFF )
OPTION( WITH_ELFICON "Enable ELF embedded icon support" OFF )
+OPTION( WITH_PCRE "Enable pcre regex support for kjs" ON )
OPTION( WITH_ASPELL "Enable aspell support" OFF )
OPTION( WITH_HSPELL "Enable hspell support" OFF )
@@ -736,6 +737,16 @@ if( WITH_ELFICON )
endif( )
+##### check for pcre ###########################
+
+if( WITH_PCRE )
+ pkg_search_module( LIBPCRE libpcre )
+ if( NOT LIBPCRE_FOUND )
+ message(FATAL_ERROR "\npcre support are requested, but not found on your system" )
+ endif( NOT LIBPCRE_FOUND )
+ set( HAVE_PCREPOSIX 1 )
+endif( )
+
##### check for aspell ##########################
# we need ASPELL_DATADIR too