summaryrefslogtreecommitdiffstats
path: root/dnssd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'dnssd/CMakeLists.txt')
-rw-r--r--dnssd/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/dnssd/CMakeLists.txt b/dnssd/CMakeLists.txt
index 1c1e40d11..8dc7ebfd8 100644
--- a/dnssd/CMakeLists.txt
+++ b/dnssd/CMakeLists.txt
@@ -11,6 +11,8 @@
include_directories(
${TQT_INCLUDE_DIRS}
+ ${AVAHI_TQT_INCLUDE_DIRS}
+ ${AVAHI_CLIENT_INCLUDE_DIRS}
${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_BINARY_DIR}
${CMAKE_BINARY_DIR}/tdecore
@@ -20,6 +22,8 @@ include_directories(
link_directories(
${TDECORE_LIBRARY_DIRS}
+ ${AVAHI_TQT_LIBRARY_DIRS}
+ ${AVAHI_CLIENT_LIBRARY_DIRS}
)
##### headers ###################################
@@ -44,6 +48,7 @@ set( ${target}_SRCS
tde_add_library( ${target} SHARED AUTOMOC
SOURCES ${${target}_SRCS}
VERSION 1.0.0
- LINK tdecore-shared ${AVAHI_TQT_LIBRARIES} ${AVAHI_CLIENT_LIBRARIES}
+ LINK tdecore-shared
+ LINK_PRIVATE ${AVAHI_TQT_LIBRARIES} ${AVAHI_CLIENT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)