summaryrefslogtreecommitdiffstats
path: root/doc/kspell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/kspell/CMakeLists.txt')
-rw-r--r--doc/kspell/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/doc/kspell/CMakeLists.txt b/doc/kspell/CMakeLists.txt
index e69de29bb..bdad90631 100644
--- a/doc/kspell/CMakeLists.txt
+++ b/doc/kspell/CMakeLists.txt
@@ -0,0 +1,21 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_custom_command(
+ OUTPUT index.cache.bz2
+ COMMAND ${CMAKE_BINARY_DIR}/kdoctools/meinproc --srcdir=${CMAKE_SOURCE_DIR}/kdoctools --check --cache index.cache.bz2 ${CMAKE_CURRENT_SOURCE_DIR}/index.docbook
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/index.docbook meinproc )
+
+install( FILES
+ index.docbook ${CMAKE_CURRENT_BINARY_DIR}/index.cache.bz2
+ DESTINATION ${HTML_INSTALL_DIR}/en/kspell )
+
+add_custom_target( kspell-doc ALL DEPENDS index.cache.bz2 )