summaryrefslogtreecommitdiffstats
path: root/interfaces/tdeimproxy/interface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'interfaces/tdeimproxy/interface/CMakeLists.txt')
-rw-r--r--interfaces/tdeimproxy/interface/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/interfaces/tdeimproxy/interface/CMakeLists.txt b/interfaces/tdeimproxy/interface/CMakeLists.txt
index d62819ed8..1c722de02 100644
--- a/interfaces/tdeimproxy/interface/CMakeLists.txt
+++ b/interfaces/tdeimproxy/interface/CMakeLists.txt
@@ -18,5 +18,14 @@ install( FILES
##### other data ################################
-install( FILES kcm_instantmessenger.desktop DESTINATION ${DATA_INSTALL_DIR}/kcm_componentchooser )
-install( FILES dcopinstantmessenger.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kcm_instantmessenger.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kcm_componentchooser
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/interfaces-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE dcopinstantmessenger.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/interfaces-desktops
+)