summaryrefslogtreecommitdiffstats
path: root/kabc/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kabc/tests/CMakeLists.txt')
-rw-r--r--kabc/tests/CMakeLists.txt116
1 files changed, 116 insertions, 0 deletions
diff --git a/kabc/tests/CMakeLists.txt b/kabc/tests/CMakeLists.txt
new file mode 100644
index 000000000..1b739c194
--- /dev/null
+++ b/kabc/tests/CMakeLists.txt
@@ -0,0 +1,116 @@
+#################################################
+#
+# (C) 2016 Slávek Banko
+# slavek.banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_BINARY_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}/kdeui
+ ${CMAKE_SOURCE_DIR}/kio
+ ${CMAKE_SOURCE_DIR}/kio/kio
+ ${CMAKE_BINARY_DIR}/kabc
+ ${CMAKE_SOURCE_DIR}/kabc
+ ${CMAKE_SOURCE_DIR}/kab
+ ${CMAKE_SOURCE_DIR}/kabc/plugins/sql
+ ${CMAKE_SOURCE_DIR}/kabc/vcardparser
+ ${CMAKE_SOURCE_DIR}/kabc/vcard/include
+ ${CMAKE_SOURCE_DIR}/kabc/vcard/include/generated
+ ${CMAKE_SOURCE_DIR}/kabc/vcardparser
+)
+
+link_directories(
+ ${TDECORE_LIBRARY_DIRS}
+)
+
+set( TDEABC_TESTS_LINK
+ ${TQT_LIBRARIES}
+ DCOP-shared
+ kdecore-shared
+ kdeui-shared
+ kdefx-shared
+ kio-shared
+ ktexteditor-shared
+ kabc-shared
+)
+
+
+##### test programs ##############################
+
+tde_add_executable( testlock
+ SOURCES testlock.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( testldapclient
+ SOURCES testldapclient.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( testkabc
+ SOURCES testkabc.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( testaddressee
+ SOURCES testaddressee.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( testaddresseelist
+ SOURCES testaddresseelist.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( testaddressfmt
+ SOURCES testaddressfmt.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( testkabcdlg
+ SOURCES testkabcdlg.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( testdistlist
+ SOURCES testdistlist.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( testaddresslineedit
+ SOURCES testaddresslineedit.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK}
+)
+
+tde_add_executable( bigread
+ SOURCES bigread.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK} kabc_file-shared
+)
+
+tde_add_executable( bigwrite
+ SOURCES bigwrite.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK} kabc_file-shared
+)
+
+# Plugin ResourceSql is not built == can not be tested
+#
+# tde_add_executable( testdb
+# SOURCES testdb.cpp AUTOMOC
+# LINK ${TDEABC_TESTS_LINK} kabc_file-shared
+# )
+
+tde_add_executable( kabcargl
+ SOURCES kabcargl.cpp AUTOMOC
+ LINK ${TDEABC_TESTS_LINK} kabc_file-shared
+)