summaryrefslogtreecommitdiffstats
path: root/kate/plugins/autobookmarker/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kate/plugins/autobookmarker/Makefile.am')
-rw-r--r--kate/plugins/autobookmarker/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kate/plugins/autobookmarker/Makefile.am b/kate/plugins/autobookmarker/Makefile.am
new file mode 100644
index 000000000..748dbb2e5
--- /dev/null
+++ b/kate/plugins/autobookmarker/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = -I$(top_srcdir)/interfaces $(all_includes)
+METASOURCES = AUTO
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = ktexteditor_autobookmarker.la
+
+ktexteditor_autobookmarker_la_SOURCES = autobookmarker.cpp
+ktexteditor_autobookmarker_la_LIBADD = $(top_builddir)/interfaces/ktexteditor/libktexteditor.la
+ktexteditor_autobookmarker_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+
+kde_services_DATA = ktexteditor_autobookmarker.desktop
+
+confdir=$(kde_confdir)
+conf_DATA = ktexteditor_autobookmarkerrc
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/ktexteditor_autobookmarker.pot