summaryrefslogtreecommitdiffstats
path: root/kdecore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kdecore/CMakeLists.txt')
-rw-r--r--kdecore/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/kdecore/CMakeLists.txt b/kdecore/CMakeLists.txt
index 3e37ed20c..efe2c8f3c 100644
--- a/kdecore/CMakeLists.txt
+++ b/kdecore/CMakeLists.txt
@@ -129,7 +129,7 @@ tde_add_library( ${target} SHARED AUTOMOC
SOURCES ${${target}_SRCS}
VERSION 4.2.0
EMBED kdecorenetwork-static
- LINK ltdlc-static ${KDESVGICONS} DCOP-shared kdefx-shared ${ZLIB_LIBRARIES} ${LIBIDN_LIBRARIES} ICE SM
+ LINK ltdlc-static ${KDESVGICONS} DCOP-shared kdefx-shared ${ZLIB_LIBRARIES} ${LIBIDN_LIBRARIES} ${XCOMPOSITE_LIBRARIES} ICE SM
DEPENDENCIES dcopidl dcopidl2cpp
DESTINATION ${LIB_INSTALL_DIR}
)
@@ -199,3 +199,11 @@ tde_add_executable(kgrantpty SETUID
SOURCES kgrantpty.c
DESTINATION ${BIN_INSTALL_DIR}
)
+
+##### kdetcompmgr #################################
+
+tde_add_executable( kdetcompmgr
+ SOURCES kdetcompmgr.cpp
+ LINK kdecore-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)