summaryrefslogtreecommitdiffstats
path: root/kdecore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kdecore/CMakeLists.txt')
-rw-r--r--kdecore/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/kdecore/CMakeLists.txt b/kdecore/CMakeLists.txt
index 06453cfc7..a0563313d 100644
--- a/kdecore/CMakeLists.txt
+++ b/kdecore/CMakeLists.txt
@@ -129,8 +129,9 @@ tde_add_library( ${target} SHARED AUTOMOC
SOURCES ${${target}_SRCS}
VERSION 4.2.0
EMBED kdecorenetwork-static
- LINK ltdlc-static ${KDESVGICONS} DCOP-shared kdefx-shared ${ZLIB_LIBRARIES} ${LIBIDN_LIBRARIES} ${XCOMPOSITE_LIBRARIES} ICE SM
- ${LIBBFD_LIBRARIES} util
+ LINK DCOP-shared kdefx-shared ICE SM ${ZLIB_LIBRARIES}
+ LINK_PRIVATE ltdlc-static ${KDESVGICONS} ${XCOMPOSITE_LIBRARIES}
+ ${LIBIDN_LIBRARIES} ${LIBBFD_LIBRARIES} ${LIB_UTIL}
DESTINATION ${LIB_INSTALL_DIR}
)