summaryrefslogtreecommitdiffstats
path: root/kdecore/kconfig_compiler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdecore/kconfig_compiler/Makefile.am')
-rw-r--r--kdecore/kconfig_compiler/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kdecore/kconfig_compiler/Makefile.am b/kdecore/kconfig_compiler/Makefile.am
new file mode 100644
index 000000000..cfecd8408
--- /dev/null
+++ b/kdecore/kconfig_compiler/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = example tests
+
+AM_CPPFLAGS = -I$(top_srcdir)/kdecore -I$(top_srcdir) $(all_includes)
+
+bin_PROGRAMS = kconfig_compiler
+
+kconfig_compiler_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kconfig_compiler_LDADD = $(LIB_KDECORE)
+kconfig_compiler_SOURCES = kconfig_compiler.cpp
+
+TESTFILES = test1.kcfg test2.kcfg test3.kcfg test4.kcfg test_dpointer.kcfg
+
+check-local:
+ for i in $(TESTFILES); \
+ do xmllint --noout --schema $(srcdir)/kcfg.xsd $(srcdir)/tests/$$i; \
+ perl $(top_srcdir)/kdecore/kconfig_compiler/checkkcfg.pl \
+ $(top_srcdir)/kdecore/kconfig_compiler/tests/$$i; done
+