summaryrefslogtreecommitdiffstats
path: root/kdefx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kdefx/CMakeLists.txt')
-rw-r--r--kdefx/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/kdefx/CMakeLists.txt b/kdefx/CMakeLists.txt
new file mode 100644
index 000000000..7e89cd047
--- /dev/null
+++ b/kdefx/CMakeLists.txt
@@ -0,0 +1,52 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions(
+ ${TQT_CFLAGS_OTHER}
+)
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}/kdecore
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ kpixmap.h kpixmapsplitter.h kpixmapeffect.h
+ kimageeffect.h kdrawutil.h kstyle.h kcpuinfo.h
+ DESTINATION ${INCLUDE_INSTALL_DIR} )
+
+
+##### libkdefx ##################################
+
+set( target kdefx )
+
+set( ${target}_SRCS
+ kpixmap.cpp kpixmapsplitter.cpp kpixmapeffect.cpp
+ kimageeffect.cpp kdrawutil.cpp kstyle.cpp kcpuinfo.cpp
+)
+
+tde_add_library( ${target} SHARED AUTOMOC
+ SOURCES ${${target}_SRCS}
+ VERSION 4.2.0
+ LINK ${TQT_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+)