summaryrefslogtreecommitdiffstats
path: root/kdemm/volumecontrold/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdemm/volumecontrold/Makefile.am')
-rw-r--r--kdemm/volumecontrold/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/kdemm/volumecontrold/Makefile.am b/kdemm/volumecontrold/Makefile.am
new file mode 100644
index 000000000..b7c7ca729
--- /dev/null
+++ b/kdemm/volumecontrold/Makefile.am
@@ -0,0 +1,31 @@
+# This file is part of the KDE project
+# Copyright (C) 2004 Matthias Kretz <kretz@kde.org>
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License version 2 as published by the Free Software Foundation.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU Library General Public License
+# along with this library; see the file COPYING.LIB. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+
+INCLUDES = -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = kded_volumecontrold.la
+
+kded_volumecontrold_la_LDFLAGS = $(all_libraries) -module -avoid-version
+kded_volumecontrold_la_LIBADD = ../libkdemm.la
+kded_volumecontrold_la_SOURCES = volumecontrold.cpp volumecontrold.skel
+
+METASOURCES = AUTO
+
+noinst_HEADERS = volumecontrold.h
+
+services_DATA = volumecontrold.desktop
+servicesdir = $(kde_servicesdir)/kded