summaryrefslogtreecommitdiffstats
path: root/kglib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kglib/CMakeLists.txt')
-rw-r--r--kglib/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/kglib/CMakeLists.txt b/kglib/CMakeLists.txt
new file mode 100644
index 000000000..293a09e75
--- /dev/null
+++ b/kglib/CMakeLists.txt
@@ -0,0 +1,37 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ TGlibEventLoop.h
+ DESTINATION ${INCLUDE_INSTALL_DIR} )
+
+
+
+#### kglib ######################################
+
+tde_add_library( kglib SHARED
+ SOURCES TGlibEventLoop.cpp
+ VERSION 0.0.0
+ LINK ${TQT_LIBRARIES} ${GLIB2_LIBRARIES} ${GOBJECT2_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+)