summaryrefslogtreecommitdiffstats
path: root/kio/kioexec/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kio/kioexec/CMakeLists.txt')
-rw-r--r--kio/kioexec/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/kio/kioexec/CMakeLists.txt b/kio/kioexec/CMakeLists.txt
index 995141c0d..043f017c6 100644
--- a/kio/kioexec/CMakeLists.txt
+++ b/kio/kioexec/CMakeLists.txt
@@ -43,7 +43,4 @@ tde_add_executable( ${target} AUTOMOC
DESTINATION ${BIN_INSTALL_DIR}
)
-# FIXME need a review
-# create symlink to kfmexec
-file( WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_kfmexec_symlink.cmake "exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${target} \"\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${BIN_INSTALL_DIR}/kfmexec\")\n")
-set_target_properties( ${target} PROPERTIES POST_INSTALL_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/make_kfmexec_symlink.cmake)
+tde_install_symlink( ${target} ${BIN_INSTALL_DIR}/kfmexec )