summaryrefslogtreecommitdiffstats
path: root/kio/kioexec/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kio/kioexec/Makefile.am')
-rw-r--r--kio/kioexec/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/kio/kioexec/Makefile.am b/kio/kioexec/Makefile.am
new file mode 100644
index 000000000..8de01676c
--- /dev/null
+++ b/kio/kioexec/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = $(all_includes)
+
+bin_PROGRAMS = kioexec
+
+kioexec_SOURCES = main.cpp
+kioexec_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kioexec_LDADD = $(LIB_KIO)
+
+noinst_HEADERS = main.h
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) $(kioexec_SOURCES) -o $(podir)/kioexec.pot
+
+install-exec-local:
+ @rm -f $(DESTDIR)$(bindir)/kfmexec
+ @$(LN_S) kioexec $(DESTDIR)$(bindir)/kfmexec
+
+include $(top_srcdir)/admin/Doxyfile.am