summaryrefslogtreecommitdiffstats
path: root/kio/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kio/tests/CMakeLists.txt')
-rw-r--r--kio/tests/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/kio/tests/CMakeLists.txt b/kio/tests/CMakeLists.txt
index 9c4fb7427..02ffd9eb5 100644
--- a/kio/tests/CMakeLists.txt
+++ b/kio/tests/CMakeLists.txt
@@ -11,8 +11,14 @@
include_directories(
${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/dcop
${CMAKE_BINARY_DIR}/kdecore
${CMAKE_SOURCE_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}/kdeui
+ ${CMAKE_SOURCE_DIR}/kio
+ ${CMAKE_SOURCE_DIR}/kio/kfile
${CMAKE_SOURCE_DIR}/kio/kio
)
@@ -34,3 +40,37 @@ tde_add_executable( ${target}
LINK kio-shared
DESTINATION ${BIN_INSTALL_DIR}
)
+
+
+##### check and test ##############################
+
+# Force assertions to work
+add_definitions( -UNDEBUG )
+
+set( CHECKS
+ getalltest jobtest kdcopcheck kdefaultprogresstest kdirlistertest
+ kdirwatchtest kfiltertest kionetrctest kiopassdlgtest kmfitest kmimefromext
+ kmimemagictest kpropsdlgtest kprotocolinfotest kruntest kscantest kshredtest
+ ktartest kurifiltertest kurlcompletiontest kziptest metatest netaccesstest
+ previewtest speed kioslavetest ksycocatest ksycocaupdatetest
+)
+
+foreach( _check ${CHECKS} )
+ tde_add_check_executable( ${_check} AUTOMOC LINK kio-shared )
+endforeach( )
+
+# NOTE some apps here are suitable to be run as tests but not included due to
+# following reasons:
+# - jobtest may fail if run on an unusual system configuration
+# and requires GUI
+# - kprotocolinfotest tries to connect to network and requires running DCOP
+# - kurifiltertest requires network access and GUI
+# - ksycocatest requires installed kdebase and GUI
+
+set( TESTS dataprotocoltest kacltest kmimetypetest )
+
+foreach( _check ${TESTS} )
+ tde_add_check_executable( ${_check} AUTOMOC LINK kio-shared TEST)
+endforeach( )
+
+# TODO add kdirwatchunittest