summaryrefslogtreecommitdiffstats
path: root/kparts/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kparts/tests/Makefile.am')
-rw-r--r--kparts/tests/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/kparts/tests/Makefile.am b/kparts/tests/Makefile.am
new file mode 100644
index 000000000..8474e1132
--- /dev/null
+++ b/kparts/tests/Makefile.am
@@ -0,0 +1,46 @@
+
+INCLUDES= -I$(top_srcdir) -I$(top_srcdir)/libltdl -I$(top_srcdir)/kfile -I$(top_srcdir)/kio $(all_includes)
+AM_LDFLAGS = $(all_libraries)
+LDADD = $(LIB_KPARTS)
+
+check_PROGRAMS = kpartstest normalktmtest ghostviewtest
+
+kpartstest_SOURCES = example.cpp parts.cpp
+kpartstest_LDADD = libnotepad.la $(LIB_KPARTS)
+normalktmtest_SOURCES = normalktm.cpp parts.cpp
+normalktmtest_LDADD = libnotepad.la $(LIB_KPARTS)
+ghostviewtest_SOURCES = ghostview.cpp
+ghostviewtest_LDADD = $(LIB_KPARTS)
+
+# These are not really libraries, but modules dynamically opened.
+# So they should be installed in kde_module_dir, which is usually $prefix/lib/kde3
+kde_module_LTLIBRARIES = libspellcheckplugin.la libnotepadpart.la
+
+libspellcheckplugin_la_SOURCES = plugin_spellcheck.cpp
+libspellcheckplugin_la_LIBADD = $(LIB_KPARTS)
+libspellcheckplugin_la_LDFLAGS = -module $(KDE_PLUGIN)
+
+libnotepadpart_la_SOURCES = notepadpart.cpp
+libnotepadpart_la_LIBADD = libnotepad.la $(LIB_KPARTS)
+libnotepadpart_la_LDFLAGS = -module $(KDE_PLUGIN)
+
+noinst_LTLIBRARIES = libnotepad.la
+libnotepad_la_SOURCES = notepad.cpp
+
+rcdir = $(kde_datadir)/kpartstest
+rc_DATA = kpartstest_shell.rc
+
+testpartdir = $(kde_datadir)/kpartstestpart
+testpart_DATA = kpartstest_part1.rc
+
+notepaddir = $(kde_datadir)/notepadpart
+notepad_DATA = notepadpart.rc
+
+ghostviewtestdir = $(kde_datadir)/ghostviewtest
+ghostviewtest_DATA = ghostviewtest_shell.rc
+
+pluginsdir = $(kde_datadir)/notepadpart/kpartplugins
+plugins_DATA = plugin_foobar.rc plugin_spellcheck.rc
+
+METASOURCES = AUTO
+