summaryrefslogtreecommitdiffstats
path: root/kspell2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kspell2/CMakeLists.txt')
-rw-r--r--kspell2/CMakeLists.txt62
1 files changed, 62 insertions, 0 deletions
diff --git a/kspell2/CMakeLists.txt b/kspell2/CMakeLists.txt
new file mode 100644
index 000000000..ac2df9720
--- /dev/null
+++ b/kspell2/CMakeLists.txt
@@ -0,0 +1,62 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( ui )
+add_subdirectory( plugins )
+
+add_definitions(
+ ${TQT_CFLAGS_OTHER}
+)
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}/kdeui
+ ${CMAKE_SOURCE_DIR}/kutils
+ ${CMAKE_SOURCE_DIR}/kio
+ ${CMAKE_SOURCE_DIR}/kio/kio
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ settings.h filter.h dictionary.h broker.h
+ backgroundchecker.h defaultdictionary.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kspell2 )
+
+
+##### other data ################################
+
+install( FILES kspellclient.desktop DESTINATION ${SHARE_INSTALL_DIR}/servicetypes )
+
+
+#### kspell2base ################################
+
+set( target kspell2base )
+
+set( ${target}_SRCS
+ settings.cpp broker.cpp client.cpp filter.cpp
+ backgroundchecker.cpp backgroundthread.cpp
+ backgroundengine.cpp defaultdictionary.cpp
+)
+
+tde_add_library( ${target} STATIC_PIC AUTOMOC
+ SOURCES ${${target}_SRCS}
+)