summaryrefslogtreecommitdiffstats
path: root/kspell2/plugins/aspell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kspell2/plugins/aspell/CMakeLists.txt')
-rw-r--r--kspell2/plugins/aspell/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/kspell2/plugins/aspell/CMakeLists.txt b/kspell2/plugins/aspell/CMakeLists.txt
new file mode 100644
index 000000000..09b245cb1
--- /dev/null
+++ b/kspell2/plugins/aspell/CMakeLists.txt
@@ -0,0 +1,48 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions(
+ ${TQT_CFLAGS_OTHER}
+)
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}/kspell2
+ ${CMAKE_SOURCE_DIR}/kdecore
+ ${ASPELL_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ASPELL_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES kspell_aspell.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+#### kspell_aspell ##############################
+
+set( target kspell_aspell )
+
+set( ${target}_SRCS
+ kspell_aspellclient.cpp kspell_aspelldict.cpp
+)
+
+tde_add_kpart( ${target} SHARED AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK kspell2-shared ${ASPELL_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)