summaryrefslogtreecommitdiffstats
path: root/kstyles/utils/installtheme/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kstyles/utils/installtheme/Makefile.am')
-rw-r--r--kstyles/utils/installtheme/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kstyles/utils/installtheme/Makefile.am b/kstyles/utils/installtheme/Makefile.am
new file mode 100644
index 000000000..ff222bad0
--- /dev/null
+++ b/kstyles/utils/installtheme/Makefile.am
@@ -0,0 +1,18 @@
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+
+####### This part is very settheme specific
+# you can add here more. This one gets installed
+bin_PROGRAMS = kinstalltheme
+
+# Which sources should be compiled for settheme.
+kinstalltheme_SOURCES = main.cpp
+
+# the library search path.
+kinstalltheme_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+# the libraries to link against. Be aware of the order. First the libraries,
+# that depend on the following ones.
+kinstalltheme_LDADD = $(LIB_KDEUI)
+