summaryrefslogtreecommitdiffstats
path: root/kwallet/backend/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kwallet/backend/Makefile.am')
-rw-r--r--kwallet/backend/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/kwallet/backend/Makefile.am b/kwallet/backend/Makefile.am
new file mode 100644
index 000000000..9727718b5
--- /dev/null
+++ b/kwallet/backend/Makefile.am
@@ -0,0 +1,25 @@
+
+INCLUDES = -I$(srcdir)/../client $(all_includes)
+
+lib_LTLIBRARIES = libkwalletbackend.la
+
+libkwalletbackend_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) -version-info 1:0 -no-undefined
+libkwalletbackend_la_LIBADD = $(LIB_QT) ../../kdecore/libkdecore.la
+libkwalletbackend_la_SOURCES = blockcipher.cc \
+ blowfish.cc \
+ cbc.cc \
+ sha1.cc \
+ kwalletentry.cc \
+ kwalletbackend.cc
+
+
+libkwalletbackend_la_METASOURCES = AUTO
+
+noinst_HEADERS = blowfishtables.h \
+ cbc.h \
+ sha1.h \
+ blockcipher.h \
+ kwalletentry.h \
+ kwalletbackend.h \
+ blowfish.h
+