summaryrefslogtreecommitdiffstats
path: root/kwallet/backend/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kwallet/backend/tests/CMakeLists.txt')
-rw-r--r--kwallet/backend/tests/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/kwallet/backend/tests/CMakeLists.txt b/kwallet/backend/tests/CMakeLists.txt
new file mode 100644
index 000000000..5f79bd5d9
--- /dev/null
+++ b/kwallet/backend/tests/CMakeLists.txt
@@ -0,0 +1,33 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/kwallet/client
+ ${CMAKE_SOURCE_DIR}/kwallet/backend
+ ${CMAKE_BINARY_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}/kdecore
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+tde_add_check_executable( backendtest AUTOMOC
+ LINK kwalletbackend-shared kwalletclient-shared TEST )
+tde_add_check_executable( testbf AUTOMOC
+ LINK kwalletbackend-shared kwalletclient-shared TEST )
+tde_add_check_executable( testsha AUTOMOC
+ LINK kwalletbackend-shared kwalletclient-shared TEST )