summaryrefslogtreecommitdiffstats
path: root/mimetypes/inode/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mimetypes/inode/CMakeLists.txt')
-rw-r--r--mimetypes/inode/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/mimetypes/inode/CMakeLists.txt b/mimetypes/inode/CMakeLists.txt
index 34115a827..3c19fac8b 100644
--- a/mimetypes/inode/CMakeLists.txt
+++ b/mimetypes/inode/CMakeLists.txt
@@ -11,7 +11,13 @@
##### other data ################################
-install( FILES
+foreach( _mimetype
block.desktop chardevice.desktop directory-locked.desktop
directory.desktop fifo.desktop socket.desktop
- DESTINATION ${MIME_INSTALL_DIR}/inode )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_mimetype}
+ DESTINATION ${MIME_INSTALL_DIR}/inode
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/mimetypes
+ )
+endforeach()