summaryrefslogtreecommitdiffstats
path: root/tdecore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdecore/CMakeLists.txt')
-rw-r--r--tdecore/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tdecore/CMakeLists.txt b/tdecore/CMakeLists.txt
index 2e00d6afa..f0ea3b5b4 100644
--- a/tdecore/CMakeLists.txt
+++ b/tdecore/CMakeLists.txt
@@ -14,6 +14,13 @@ add_subdirectory( network )
add_subdirectory( kconfig_compiler )
add_subdirectory( hwlibdata )
+if( NOT DBUS_SYSTEM_BUS )
+ set( DBUS_SYSTEM_BUS "unix:path=/var/run/dbus/system_bus_socket" CACHE INTERNAL "" FORCE )
+endif()
+
+if( WITH_UPOWER )
+ add_definitions( -DWITH_UPOWER )
+endif( )
if( WITH_LIBART )
add_subdirectory( svgicons )