summaryrefslogtreecommitdiffstats
path: root/tdehtml/tdemultipart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdehtml/tdemultipart/Makefile.am')
-rw-r--r--tdehtml/tdemultipart/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tdehtml/tdemultipart/Makefile.am b/tdehtml/tdemultipart/Makefile.am
new file mode 100644
index 000000000..f02b5931e
--- /dev/null
+++ b/tdehtml/tdemultipart/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = -I$(top_srcdir)/tdehtml -I$(top_srcdir)/kio/httpfilter -I$(top_srcdir)/tdeutils $(all_includes)
+
+# These are not really libraries, but modules dynamically opened.
+# So they should be installed in kde_module_dir, which is usually $kde_prefix/lib/trinity
+kde_module_LTLIBRARIES = libtdemultipart.la
+
+libtdemultipart_la_SOURCES = tdemultipart.cpp
+libtdemultipart_la_LIBADD = $(LIB_KPARTS) $(top_builddir)/kio/httpfilter/libhttpfilter.la $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) $(LIB_KFILE) $(LIBZ)
+libtdemultipart_la_DEPENDENCIES = $(LIB_KPARTS)
+libtdemultipart_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+
+# Automatically generate moc files
+METASOURCES = AUTO
+
+# Install the .desktop file into the kde_services directory
+kde_services_DATA = tdemultipart.desktop
+