summaryrefslogtreecommitdiffstats
path: root/tdeio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeio/CMakeLists.txt')
-rw-r--r--tdeio/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tdeio/CMakeLists.txt b/tdeio/CMakeLists.txt
index 103a67fb7..2a8fc7f3a 100644
--- a/tdeio/CMakeLists.txt
+++ b/tdeio/CMakeLists.txt
@@ -94,6 +94,7 @@ tde_add_library( ${target} SHARED
SOURCES ${CMAKE_CURRENT_BINARY_DIR}/dummy.cpp
VERSION 14.0.0
EMBED kssl-static tdeiocore-static tdesycoca-static kbookmarks-static tdefile-static ${ELFICON_STATIC_LIB}
- LINK ltdlc-static tdeui-shared tdesu-shared tdewalletclient-shared ${LIBR_LIBRARIES} ${ACL_LIBRARIES}
+ LINK tdeui-shared tdewalletclient-shared
+ LINK_PRIVATE ltdlc-static tdesu-shared ${LIBR_LIBRARIES} ${ACL_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)