summaryrefslogtreecommitdiffstats
path: root/tdeio/misc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeio/misc/CMakeLists.txt')
-rw-r--r--tdeio/misc/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tdeio/misc/CMakeLists.txt b/tdeio/misc/CMakeLists.txt
index 1f60c22e5..0b75b5103 100644
--- a/tdeio/misc/CMakeLists.txt
+++ b/tdeio/misc/CMakeLists.txt
@@ -46,12 +46,18 @@ install( FILES uiserver.h DESTINATION ${INCLUDE_INSTALL_DIR}/tdeio )
##### other data ################################
-install(FILES
+foreach( _service
tdeio_uiserver.desktop tdemailservice.protocol
telnet.protocol rlogin.protocol rtsp.protocol
ssh.protocol mms.protocol mmst.protocol mmsu.protocol
pnm.protocol rtspt.protocol rtspu.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_service}
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeio-desktops
+ )
+endforeach()
install( FILES fileshareset DESTINATION ${BIN_INSTALL_DIR}
PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_EXECUTE WORLD_EXECUTE SETUID )