summaryrefslogtreecommitdiffstats
path: root/tdeioslave/http/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeioslave/http/CMakeLists.txt')
-rw-r--r--tdeioslave/http/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tdeioslave/http/CMakeLists.txt b/tdeioslave/http/CMakeLists.txt
index aff6d0a4e..c29782570 100644
--- a/tdeioslave/http/CMakeLists.txt
+++ b/tdeioslave/http/CMakeLists.txt
@@ -32,10 +32,16 @@ link_directories(
##### other data ################################
-install( FILES
+foreach( _desktop
http_cache_cleaner.desktop http.protocol https.protocol
webdav.protocol webdavs.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeioslave-desktops
+ )
+endforeach()
##### tdeio_http_cache_cleaner ####################